클라우드 마이그레이션 아키텍트 키트
자신 있는 워크로드 이전: 현황, 포트폴리오와 애플리케이션별 평가(7 Rs), TCO, 랜딩 존, 네트워크, 하이브리드와 메인프레임 설계, 웨이브, 데이터 마이그레이션, 컷오버.
평가
Current-State (As-Is) Assessment Template
전체As-is baseline: applications, integrations, data, infrastructure, security (CSF 2.0), operations (DORA), quality, cost (FOCUS), contracts, findings, gaps
TOGAF 10th Ed. (baseline, gap analysis names); AWS portfolio assessment; ISO/IEC 25010:2023; NIST CSF 2.0; DORA metrics; FOCUS 1.4Legacy Modernization Assessment Template (7 Rs)
전체Portfolio inventory, value and health scoring, 7 Rs disposition, strangler fig plan, data migration, roadmap, costs and governance
7 Rs (AWS Prescriptive Guidance); strangler fig patternApplication Migration Assessment Template (7 Rs, Per Workload)
전체Workload profile, dependencies, data gravity, licensing, readiness, 7 Rs decision, target design, sizing, tests, cutover, rollback, cost before/after
AWS Prescriptive Guidance 7 Rs; Microsoft CAF migrate; Google Cloud migration phasesTotal Cost of Ownership (TCO) Analysis Template
전체Multi-year TCO comparison by cost category mapped to FOCUS 1.4, NPV discounting, unit economics, sensitivity, break-even, recommendation and FinOps handover
FinOps FOCUS 1.4 (cost concepts)
설계
Cloud Landing Zone Design Template (AWS, Azure, Google Cloud)
전체Principles, hierarchy diagram, identity and break-glass, hub-spoke and IP plan, guardrails, logging, policy as code, tagging, vending runbook, CIS mapping
Azure landing zone design areas; AWS Control Tower multi-account guidance; Google Cloud landing zone design; CIS BenchmarksNetwork Architecture Design Template (Hub-Spoke, IP Plan, Hybrid DNS)
전체Topology options, provider equivalents, IPv4/IPv6 plan, routing, hybrid link resilience, DNS, ingress/egress, segmentation, private endpoints, HA
RFC 1918; RFC 6598; RFC 4193; AWS, Azure and Google Cloud reference network topologiesHybrid and Multicloud Architecture Template (Placement, Exit, Data Act)
전체Drivers, patterns, placement criteria, cross-environment connectivity, identity federation, management plane, data portability, cost, exit plans
Regulation (EU) 2023/2854 (Data Act) Chapter VI; Google Cloud hybrid and multicloud patternsMainframe Modernization Design Template (COBOL, CICS, Batch, Data)
전체Estate inventory, rules extraction, pattern per app, target mapping, CICS/IMS and batch design, EBCDIC and COMP-3 conversion, strangler increments, parallel run
Strangler fig pattern (Fowler); AWS Transform for mainframe; Azure Architecture Center mainframe refactor guidance
계획
Cloud Migration Wave Plan Template (7 Rs, Cutover Runbook)
전체Discovery, dependency map, 7 Rs dispositions, move groups and waves, gantt calendar, cutover runbook, rollback triggers, hypercare, KPIs, retrospective
AWS Prescriptive Guidance 7 Rs and large migration phases; Microsoft CAF migration planningData Migration Strategy Template (Mapping, Mock Loads, Reconciliation)
전체Object inventory, profiling, cleansing, mapping, big bang vs phased vs trickle, load sequence, mock loads, reconciliation design, cutover steps, fallback
DAMA-DMBOK2 Revised (2024) knowledge areas; SAP Activate and Dynamics 365 migration stagesCutover Plan and Runbook Template
전체Cutover strategy, command centre RACI, entry criteria and freezes, rehearsals, T-minus timeline, runbook, go/no-go, point of no return, rollback, sign-off
AWS large migration playbooks (T-minus gates); Dynamics 365 go-live checklist
운영
Cloud Cost Review Template (FinOps FOCUS 1.4)
전체Cloud cost review on FOCUS 1.4: data basis, invoice reconciliation, charge categories, cost by service and team, unit economics, commitments, savings, tagging
FinOps FOCUS 1.4; FinOps Framework 2026 (phases, domains, capabilities)Sustainability Architecture Assessment Template (SCI, ISO/IEC 21031)
전체Boundary, functional unit, SCI method (E, I, M, R), factor sources, baseline, hotspots, levers, recomputed scenarios, trade-offs, targets, monitoring
ISO/IEC 21031:2024 (SCI); GSF SCI 1.1.0; AWS, Azure and Google Cloud Well-Architected sustainability guidance; GHG Protocol scopesHypercare Plan Template
전체Post-go-live support: duration, support tiers and rota, daily cadence, severity targets, monitoring, known issues, triage, KPIs, exit criteria, handoff
AWS Prescriptive Guidance (hypercare); Dynamics 365 implementation guide