Markdown Editor

Набір мейнтейнера open source

README, посібник для контриб'юторів, кодекс поведінки, управління, CODEOWNERS, версіонування, changelog, політика безпеки, розкриття вразливостей, базовий рівень OpenSSF і SBOM.

Крок 1

Основи

  1. Detailed README Template

    Повний

    Heavyweight README (Best-README structure) – TOC, shields refs

    Best-README-Template
  2. CONTRIBUTING.md Template

    Стандарт

    CONTRIBUTING – setup, workflow, gates

  3. Code of Conduct Template (Contributor Covenant)

    Стандарт

    Contributor Covenant 2.1 adapted (CC BY 4.0)

    Contributor Covenant 2.1
  4. GOVERNANCE.md Template

    Компактний

    GOVERNANCE.md – roles, decision process

    GitHub community health conventions
  5. Code Ownership Policy Template (CODEOWNERS)

    Повний

    Code ownership policy: ownership models, RACI, MUST/SHOULD rules, CODEOWNERS standard and example, review SLAs, escalation, orphaned code, transfers, metrics

    GitHub and GitLab code owners documentation; SLSA 1.2 Source track
Крок 2

Випуск і передавання

  1. Versioning and Release Policy Template (SemVer, CalVer, CRA)

    Повний

    Versioning policy: SemVer or CalVer rules, release types and cadence, changelog conventions, support tiers, LTS, CRA support period, backports, yanking

    SemVer 2.0.0; CalVer 26.0; Conventional Commits 1.0.0; Keep a Changelog 1.1.0; CRA Art. 13(8)-(11)
  2. Changelog Template (Keep a Changelog)

    Стандарт

    Keep a Changelog + SemVer

    Keep a Changelog
  3. Release Notes Template

    Стандарт

    Release notes: highlights, features, fixes, breaking changes with migration, deprecations with deprecation and sunset dates, CVE fixes, known issues, upgrade steps

    Semantic Versioning 2.0.0; RFC 9745 and RFC 8594 headers
Крок 3

Безпека

  1. SECURITY.md Security Policy Template

    Повний

    SECURITY.md: supported versions, private reporting channels, response targets, embargo, safe harbour, CVE and advisories, security.txt, CRA note

    ISO/IEC 29147:2018 (structure); RFC 9116; CRA Art. 14
  2. Vulnerability Disclosure Policy Template (ISO/IEC 29147, security.txt)

    Повний

    Public CVD policy: scope, safe harbour, reporting channels, response timelines, embargo, CVE and advisories, credit, CRA notes, ready RFC 9116 security.txt

    ISO/IEC 29147:2018 (structure); RFC 9116; EU CRA Art. 13, 14
  3. OSS Project Security Baseline Template (OpenSSF OSPS, Scorecard)

    Повний

    OSPS Baseline self-assessment: target level, 64 requirements by family with evidence, Scorecard results, level summary, remediation plan

    OpenSSF OSPS Baseline v2026.08.28; OpenSSF Scorecard v5.6.0
  4. SBOM and VEX Policy Template (CISA 2026, CycloneDX, SPDX)

    Повний

    SBOM production, signing, VEX rules, distribution, supplier SBOMs, retention, exceptions, metrics, CISA 2026 to CycloneDX and SPDX field map

    CISA 2026 SBOM Minimum Elements; CycloneDX 1.7; SPDX 3.0.1; CISA VEX