Markdown Editor

Open Source Maintainer Kit

README, contributing, code of conduct, governance, CODEOWNERS, versioning, changelog, security policy, vulnerability disclosure, OpenSSF baseline and SBOM.

Step 1

Foundation

  1. Detailed README Template

    Full

    Heavyweight README (Best-README structure) – TOC, shields refs

    Best-README-Template
  2. CONTRIBUTING.md Template

    Standard

    CONTRIBUTING – setup, workflow, gates

  3. Code of Conduct Template (Contributor Covenant)

    Standard

    Contributor Covenant 2.1 adapted (CC BY 4.0)

    Contributor Covenant 2.1
  4. GOVERNANCE.md Template

    Lean

    GOVERNANCE.md – roles, decision process

    GitHub community health conventions
  5. Code Ownership Policy Template (CODEOWNERS)

    Full

    Code ownership policy: ownership models, RACI, MUST/SHOULD rules, CODEOWNERS standard and example, review SLAs, escalation, orphaned code, transfers, metrics

    GitHub and GitLab code owners documentation; SLSA 1.2 Source track
Step 2

Release and transition

  1. Versioning and Release Policy Template (SemVer, CalVer, CRA)

    Full

    Versioning policy: SemVer or CalVer rules, release types and cadence, changelog conventions, support tiers, LTS, CRA support period, backports, yanking

    SemVer 2.0.0; CalVer 26.0; Conventional Commits 1.0.0; Keep a Changelog 1.1.0; CRA Art. 13(8)-(11)
  2. Changelog Template (Keep a Changelog)

    Standard

    Keep a Changelog + SemVer

    Keep a Changelog
  3. Release Notes Template

    Standard

    Release notes: highlights, features, fixes, breaking changes with migration, deprecations with deprecation and sunset dates, CVE fixes, known issues, upgrade steps

    Semantic Versioning 2.0.0; RFC 9745 and RFC 8594 headers
Step 3

Security

  1. SECURITY.md Security Policy Template

    Full

    SECURITY.md: supported versions, private reporting channels, response targets, embargo, safe harbour, CVE and advisories, security.txt, CRA note

    ISO/IEC 29147:2018 (structure); RFC 9116; CRA Art. 14
  2. Vulnerability Disclosure Policy Template (ISO/IEC 29147, security.txt)

    Full

    Public CVD policy: scope, safe harbour, reporting channels, response timelines, embargo, CVE and advisories, credit, CRA notes, ready RFC 9116 security.txt

    ISO/IEC 29147:2018 (structure); RFC 9116; EU CRA Art. 13, 14
  3. OSS Project Security Baseline Template (OpenSSF OSPS, Scorecard)

    Full

    OSPS Baseline self-assessment: target level, 64 requirements by family with evidence, Scorecard results, level summary, remediation plan

    OpenSSF OSPS Baseline v2026.08.28; OpenSSF Scorecard v5.6.0
  4. SBOM and VEX Policy Template (CISA 2026, CycloneDX, SPDX)

    Full

    SBOM production, signing, VEX rules, distribution, supplier SBOMs, retention, exceptions, metrics, CISA 2026 to CycloneDX and SPDX field map

    CISA 2026 SBOM Minimum Elements; CycloneDX 1.7; SPDX 3.0.1; CISA VEX