Kit arsitek solusi IoT dan OT
Solusi perangkat terhubung dan pabrik: atribut kualitas, desain edge dan jaringan, streaming, platform data, keamanan, dan ketahanan.
11 templat dalam 4 langkah, sesuai urutan penggunaan. Buka templat mana pun di editor, isi, lalu ekspor ke PDF, DOCX, atau HTML.
Perumusan masalah
Non-Functional Requirements & Quality Attribute Scenarios Template
LengkapISO/IEC 25010:2023 qualities, utility tree priorities, six-part scenarios, measurement methods and acceptance thresholds
ISO/IEC 25010:2023, SEI quality attribute scenariosSolution Architecture Document Template
LengkapSAD: drivers, current/target state, gaps, 42010 views, deployment, HA/DR per component, operability, residency, migration, NFR trace, roadmap
ISO/IEC/IEEE 42010:2022 (concerns, viewpoints, views)
Desain
Edge and IoT Solution Architecture Template (ISA-95, IEC 62443, MQTT)
LengkapIoT use cases, ISA-95 levels, device lifecycle, edge compute, OPC UA, MQTT 5.0, Sparkplug, zones and conduits, SL-T, OTA, sizing, offline, CRA
ANSI/ISA-95.00.01-2025 (levels); IEC 62443-3-2:2020, 62443-3-3:2013, 62443-4-2:2019; MQTT 5.0; Sparkplug 3.0; OPC UA 1.05; EU CRA 2024/2847Network Architecture Design Template (Hub-Spoke, IP Plan, Hybrid DNS)
LengkapTopology options, provider equivalents, IPv4/IPv6 plan, routing, hybrid link resilience, DNS, ingress/egress, segmentation, private endpoints, HA
RFC 1918; RFC 6598; RFC 4193; AWS, Azure and Google Cloud reference network topologiesStreaming Solution Design Template (Kafka, Flink, AsyncAPI)
LengkapLatency SLOs, delivery guarantees, CDC sources, AsyncAPI 3.1.0 contracts, topics, watermarks, windows, state, exactly-once, capacity, lag
AsyncAPI 3.1.0; CloudEvents 1.0.2; Apache Kafka 4.x and Apache Flink 2.x conceptsData Platform Architecture Template (Lakehouse, Medallion, Lineage)
LengkapLakehouse or warehouse architecture: consumers, ingestion, medallion layers, table formats, catalogue, OpenLineage 2-0-2 lineage, quality, security, cost
DAMA-DMBOK2 Revised (2024) knowledge areas; Apache Iceberg table spec v3; Delta Lake protocol; OpenLineage spec 2-0-2Manufacturing Integration Design Template (ISA-95, OPC UA)
LengkapERP-MES-shop floor integration: ISA-95 levels, scope split, B2MML exchanges, OPC UA, unified namespace, zones and conduits, plant rollout
ANSI/ISA-95.00.01-2025; B2MML V0700; OPC UA 1.05; MQTT 5.0; Sparkplug 3.0.0; IEC 62443-3-2
Keamanan
Threat Model Template (STRIDE)
LengkapSTRIDE threat model: scope, DFD with trust boundaries, assets, threats per element, L x I rating, mitigations, risk acceptance
STRIDESecurity Architecture Document Template (NIST SP 800-160, STRIDE)
LengkapSecurity architecture: assets, trust boundaries, STRIDE threat register, requirements, IAM, data protection, detection, residual risk
NIST SP 800-160 Vol. 1 Rev. 1 and Vol. 2 Rev. 1; NIST SP 800-63-4; STRIDE
Operasi
Resilience Tiering and HA/DR Design Template (RTO, RPO, DR Patterns)
LengkapCriticality tiers, MTD, RTO, RPO per tier, workload assignment, HA and DR patterns, data protection, topology, tier inheritance, testing, cost, exceptions
NIST SP 800-34 Rev. 1; ISO/IEC 27031:2025; AWS Well-Architected Reliability pillar DR strategiesObservability Specification Template (OpenTelemetry)
LengkapTelemetry goals, OTel semantic conventions 1.44.0 baseline with stability per area, logs, metrics, traces, optional Profiles, dashboards, SLOs, alerts, privacy, retention, cost
OpenTelemetry semantic conventions 1.44.0